Discussion:
resolved: wrong address w/ cache off, wo/ querying DNS server
(too old to reply)
Dénes Türei
2021-04-21 23:42:54 UTC
Permalink
Dear Systemd Developers,

I got stuck with investigating an issue and I would be very grateful
for some advice.
Briefly, systemd-resolved keeps returning a wrong answer to a query,
despite the cache is disabled. The debug log doesn't show the origin
of the answer. Systemd-resolved doesn't query the configured DNS
server when answering this query. If I query the DNS server directly,
it returns the correct answer. I described the issue in this thread:
https://bbs.archlinux.org/viewtopic.php?pid=1968888#p1968888 -- please
ignore the starting comment, the last 3 are the most relevant. See
some system info below the mail.

Best,

Denes

Systemd version: 247.3
Linux: Linux x 5.10.13-hardened1-1-hardened #1 SMP PREEMPT Thu, 04 Feb
2021 22:19:00 +0000 x86_64 GNU/Linux
Lennart Poettering
2021-04-22 07:52:39 UTC
Permalink
Post by Dénes Türei
Dear Systemd Developers,
I got stuck with investigating an issue and I would be very grateful
for some advice.
Briefly, systemd-resolved keeps returning a wrong answer to a query,
despite the cache is disabled. The debug log doesn't show the origin
of the answer. Systemd-resolved doesn't query the configured DNS
server when answering this query. If I query the DNS server directly,
https://bbs.archlinux.org/viewtopic.php?pid=1968888#p1968888 -- please
ignore the starting comment, the last 3 are the most relevant. See
some system info below the mail.
Maybe your local hostname or an /etc/hosts entry exist that match the
domain name you are looking up?

Lennart

--
Lennart Poettering, Berlin
Dénes Türei
2021-04-24 20:11:03 UTC
Permalink
El jue, 22 abr 2021 a las 9:52, Lennart Poettering
Post by Lennart Poettering
Post by Dénes Türei
Dear Systemd Developers,
I got stuck with investigating an issue and I would be very grateful
for some advice.
Briefly, systemd-resolved keeps returning a wrong answer to a query,
despite the cache is disabled. The debug log doesn't show the origin
of the answer. Systemd-resolved doesn't query the configured DNS
server when answering this query. If I query the DNS server directly,
https://bbs.archlinux.org/viewtopic.php?pid=1968888#p1968888 -- please
ignore the starting comment, the last 3 are the most relevant. See
some system info below the mail.
Maybe your local hostname or an /etc/hosts entry exist that match the
domain name you are looking up?
Thanks Lennart, you are right. It surprised me very much, as this was
one of my first thoughts in the beginning, but I haven't even checked
because I thought it's impossible, why a webpage should be in the
hosts file...

Best,

Denes
Post by Lennart Poettering
Lennart
--
Lennart Poettering, Berlin
Loading...