Discussion:
pkg-config[error]
(too old to reply)
Parlin Tampubolon
2018-04-28 09:41:12 UTC
Permalink
Raw Message
Hi,
Please help,
I'm linuxmint user (linuxmint 18), I always have error when to install some
app/tools. the error said,my Pkg-config error. and the impact is my
computer, can't install anything, even i use apt-get update, will back to
the error dpk-config. I use synaptic,aptitude, but still cant install
application what i want to install.

how to repair my pkg-config.i find this error on google with search key
"Can't locate Dpkg/Arch.pm", but cant find the solution.
please help me, what should i do to repair this error.

*linux-Vost # apt-get install -f*
*Reading package lists... Done*
*Building dependency tree *
*Reading state information... Done*
*Correcting dependencies... Done*
*The following additional packages will be installed:*
* libperl5.22 perl-modules-5.22*
*Recommended packages:*
* perl*
*The following packages will be REMOVED:*
* dpkg-dev pkg-config*
*The following packages will be upgraded:*
* libperl5.22 perl-modules-5.22*
*2 upgraded, 0 newly installed, 2 to remove and 429 not upgraded.*
*27 not fully installed or removed.*
*Need to get 0 B/6.048 kB of archives.*
*After this operation, 2.139 kB disk space will be freed.*
*Do you want to continue? [Y/n] Y*
*(Reading database ... 246320 files and directories currently installed.)*
*Removing pkg-config (0.29.1-0ubuntu1) ...*
*Can't locate Dpkg/Arch.pm in @INC (you may need to install the Dpkg::Arch
module) (@INC contains: /etc/perl
/usr/local/lib/x86_64-linux-gnu/perl/5.26.2 /usr/local/share/perl/5.26.2
/usr/lib/x86_64-linux-gnu/perl5/5.26 /usr/share/perl5
/usr/lib/x86_64-linux-gnu/perl/5.26 /usr/share/perl/5.26
/usr/local/lib/site_perl /usr/lib/x86_64-linux-gnu/perl-base) at
/usr/share/pkg-config-dpkghook line 14.*
*BEGIN failed--compilation aborted at /usr/share/pkg-config-dpkghook line
14.*
*dpkg: error processing package pkg-config (--remove):*
* installed pkg-config package pre-removal script subprocess returned error
exit status 2*
*dpkg: dpkg-dev: dependency problems, but removing anyway as you requested:*
* pkg-config depends on dpkg-dev.*

*Removing dpkg-dev (1.19.0.5) ...*
*Errors were encountered while processing:*
* pkg-config*
*E: Sub-process /usr/bin/dpkg returned an error code (1)*


thank you.

regards,

parlin
Ryan Gonzalez
2018-04-28 13:20:02 UTC
Permalink
Raw Message
This literally has absolutely nothing to do with systemd.

That being said, try deleting /etc/dpkg/dpkg.cfg.d/pkg-config-hook-config
and then upgrading pkg-config.

--
Ryan (ライアン)
Yoko Shimomura, ryo (supercell/EGOIST), Hiroyuki Sawano >> everyone else
https://refi64.com/



On April 28, 2018 4:42:08 AM Parlin Tampubolon <***@gmail.com>
wrote:

> Hi,
> Please help,
> I'm linuxmint user (linuxmint 18), I always have error when to install some
> app/tools. the error said,my Pkg-config error. and the impact is my
> computer, can't install anything, even i use apt-get update, will back to
> the error dpk-config. I use synaptic,aptitude, but still cant install
> application what i want to install.
>
> how to repair my pkg-config.i find this error on google with search key
> "Can't locate Dpkg/Arch.pm", but cant find the solution.
> please help me, what should i do to repair this error.
>
> *linux-Vost # apt-get install -f*
> *Reading package lists... Done*
> *Building dependency tree *
> *Reading state information... Done*
> *Correcting dependencies... Done*
> *The following additional packages will be installed:*
> * libperl5.22 perl-modules-5.22*
> *Recommended packages:*
> * perl*
> *The following packages will be REMOVED:*
> * dpkg-dev pkg-config*
> *The following packages will be upgraded:*
> * libperl5.22 perl-modules-5.22*
> *2 upgraded, 0 newly installed, 2 to remove and 429 not upgraded.*
> *27 not fully installed or removed.*
> *Need to get 0 B/6.048 kB of archives.*
> *After this operation, 2.139 kB disk space will be freed.*
> *Do you want to continue? [Y/n] Y*
> *(Reading database ... 246320 files and directories currently installed.)*
> *Removing pkg-config (0.29.1-0ubuntu1) ...*
> *Can't locate Dpkg/Arch.pm in @INC (you may need to install the Dpkg::Arch
> module) (@INC contains: /etc/perl
> /usr/local/lib/x86_64-linux-gnu/perl/5.26.2 /usr/local/share/perl/5.26.2
> /usr/lib/x86_64-linux-gnu/perl5/5.26 /usr/share/perl5
> /usr/lib/x86_64-linux-gnu/perl/5.26 /usr/share/perl/5.26
> /usr/local/lib/site_perl /usr/lib/x86_64-linux-gnu/perl-base) at
> /usr/share/pkg-config-dpkghook line 14.*
> *BEGIN failed--compilation aborted at /usr/share/pkg-config-dpkghook line
> 14.*
> *dpkg: error processing package pkg-config (--remove):*
> * installed pkg-config package pre-removal script subprocess returned error
> exit status 2*
> *dpkg: dpkg-dev: dependency problems, but removing anyway as you requested:*
> * pkg-config depends on dpkg-dev.*
>
> *Removing dpkg-dev (1.19.0.5) ...*
> *Errors were encountered while processing:*
> * pkg-config*
> *E: Sub-process /usr/bin/dpkg returned an error code (1)*
>
>
> thank you.
>
> regards,
>
> parlin
>
>
>
> ----------
> _______________________________________________
> systemd-devel mailing list
> systemd-***@lists.freedesktop.org
> https://lists.freedesktop.org/mailman/listinfo/systemd-devel
Parlin Tampubolon
2018-04-28 14:18:41 UTC
Permalink
Raw Message
hi ryan,

thank you for you replying email,
i already try to delete that file, but still can't fix with apt-get install
-f and apt-get update.

could you please give me, specify step to repair my pkg-config.
this my capture error.


​
see, a change default name pkg-config-hook-config to

*backup.config*
regards,

parlin

On Sat, Apr 28, 2018 at 8:20 PM, Ryan Gonzalez <***@gmail.com> wrote:

> This literally has absolutely nothing to do with systemd.
>
> That being said, try deleting /etc/dpkg/dpkg.cfg.d/pkg-config-hook-config
> and then upgrading pkg-config.
>
> --
> Ryan (ラむアン)
> Yoko Shimomura, ryo (supercell/EGOIST), Hiroyuki Sawano >> everyone else
> https://refi64.com/
>
>
>
> On April 28, 2018 4:42:08 AM Parlin Tampubolon <***@gmail.com>
> wrote:
>
> Hi,
>> Please help,
>> I'm linuxmint user (linuxmint 18), I always have error when to install
>> some
>> app/tools. the error said,my Pkg-config error. and the impact is my
>> computer, can't install anything, even i use apt-get update, will back to
>> the error dpk-config. I use synaptic,aptitude, but still cant install
>> application what i want to install.
>>
>> how to repair my pkg-config.i find this error on google with search key
>> "Can't locate Dpkg/Arch.pm", but cant find the solution.
>> please help me, what should i do to repair this error.
>>
>> *linux-Vost # apt-get install -f*
>> *Reading package lists... Done*
>> *Building dependency tree *
>> *Reading state information... Done*
>> *Correcting dependencies... Done*
>> *The following additional packages will be installed:*
>> * libperl5.22 perl-modules-5.22*
>> *Recommended packages:*
>> * perl*
>> *The following packages will be REMOVED:*
>> * dpkg-dev pkg-config*
>> *The following packages will be upgraded:*
>> * libperl5.22 perl-modules-5.22*
>> *2 upgraded, 0 newly installed, 2 to remove and 429 not upgraded.*
>> *27 not fully installed or removed.*
>> *Need to get 0 B/6.048 kB of archives.*
>> *After this operation, 2.139 kB disk space will be freed.*
>> *Do you want to continue? [Y/n] Y*
>> *(Reading database ... 246320 files and directories currently installed.)*
>> *Removing pkg-config (0.29.1-0ubuntu1) ...*
>> *Can't locate Dpkg/Arch.pm in @INC (you may need to install the Dpkg::Arch
>> module) (@INC contains: /etc/perl
>> /usr/local/lib/x86_64-linux-gnu/perl/5.26.2 /usr/local/share/perl/5.26.2
>> /usr/lib/x86_64-linux-gnu/perl5/5.26 /usr/share/perl5
>> /usr/lib/x86_64-linux-gnu/perl/5.26 /usr/share/perl/5.26
>> /usr/local/lib/site_perl /usr/lib/x86_64-linux-gnu/perl-base) at
>> /usr/share/pkg-config-dpkghook line 14.*
>> *BEGIN failed--compilation aborted at /usr/share/pkg-config-dpkghook line
>> 14.*
>> *dpkg: error processing package pkg-config (--remove):*
>> * installed pkg-config package pre-removal script subprocess returned
>> error
>> exit status 2*
>> *dpkg: dpkg-dev: dependency problems, but removing anyway as you
>> requested:*
>> * pkg-config depends on dpkg-dev.*
>>
>> *Removing dpkg-dev (1.19.0.5) ...*
>> *Errors were encountered while processing:*
>> * pkg-config*
>> *E: Sub-process /usr/bin/dpkg returned an error code (1)*
>>
>>
>> thank you.
>>
>> regards,
>>
>> parlin
>>
>>
>>
>> ----------
>> _______________________________________________
>> systemd-devel mailing list
>> systemd-***@lists.freedesktop.org
>> https://lists.freedesktop.org/mailman/listinfo/systemd-devel
>>
>
>
>
Lennart Poettering
2018-04-29 17:08:29 UTC
Permalink
Raw Message
On Sa, 28.04.18 16:41, Parlin Tampubolon (***@gmail.com) wrote:

> Hi,
> Please help,
> I'm linuxmint user (linuxmint 18), I always have error when to install some
> app/tools. the error said,my Pkg-config error. and the impact is my
> computer, can't install anything, even i use apt-get update, will back to
> the error dpk-config. I use synaptic,aptitude, but still cant install
> application what i want to install.

Sorry, but this is not the right place to ask questions like yours, as
it's not in any way related to the systemd project which is what this
mailing list is about. Please contact your distribution's community
for help, I am sure they will help you, but this here is not the right
place.

Sorry and thank you for understanding,

Lennart

--
Lennart Poettering, Red Hat
Loading...